Back to overview
Resolved

Dashboard is unavailable

Jul 16, 2026 at 8:40am UTC
Affected services
HR Portal (hr.talentunveiled.com)

Resolved
Jul 16, 2026 at 10:16am UTC

We’re back! The HR Portal should be up and running. Thanks for bearing with us.

Created
Jul 16, 2026 at 8:40am UTC

A third-party service we use for logins and authorization is currently experiencing an outage. This is affecting all new logins to TalentUnveiled, and some currently-logged-in users may experience degraded app functionality.

We're investigating mitigations urgently and our auth provider is also working on the issue - you can follow for updates here: https://status.workos.com/incidents/b52fkqjzcl20